EasyCLA will not report a status

Incident Report for LFX

Postmortem

Recently, we encountered a challenge related to a significant number of commits (approximately 500) from one of our clients. Our primary objective in addressing this issue was to enhance the efficiency of processing a Pull Request with a high volume of commits, prompting us to initiate a hotfix.
This hotfix incorporated the use of a Python package, 'multiprocessor'. Regrettably, this package presented unexpected compatibility issues with our AWS Lambdas. Consequently, the deployment of the hotfix in our production environment disrupted the EasyCLA service.

Posted Aug 01, 2023 - 09:24 PDT

Resolved

This issue has been resolved. The changes made to introduce the issue have been reverted and we are continuing to investigate the root cause. We will provide a post-mortem here when available.
Posted Jul 31, 2023 - 13:42 PDT

Monitoring

A fix has been implemented and we are monitoring the results. If you have an EasyCLA status of 'Expected', please comment /easycla in your PR to get the newest, correct status.
Posted Jul 31, 2023 - 09:34 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 31, 2023 - 08:24 PDT

Investigating

We are currently investigating an issue with EasyCLA that affects new PRs in Github. The status for EasyCLA will report as 'Expected'. We will update this status page with more information as we learn it.
Posted Jul 31, 2023 - 06:40 PDT
This incident affected: LFX EasyCLA (API).